fbpx

Company News

Display Search Box nowhere to be found in a SharePoint 2013 Web Part

December 31, 2012

This one was a little frustrating and not altogether obvious, so I thought I’d share the result

What

SharePoint 2013 has an amazing inline search feature for lists and libraries. I love it and it won’t be long before it is the one thing folks without 2013 moan about… The idea of being able to search within a list or library and not be taken away to a search page but rather show the results, inline with your columns (metadata) is awesomesauce.

It looks like this…

image

And it is enabled by this…

image

So What

The problem is, if you have migrated existing libraries with customizations or you have played with views in new SharePoint 2013 libraries, you might have changed the “style” from Default, to something like “Shaded” or one of the other styles (I often chose Shaded to help my users with readability).

image

As such, if the view is anything but Default, you won’t find this option “Display Search Box” under “Miscellaneous” in your web part (er, app part now…). It will be missing.

image

 

Now What

Pretty simple really as I’ve already given the clue up above:”

  • When creating views and you want to display the Search Box, stick with the “Default” Style for your view
  • Or if you have a library you have migrated into SharePoint 2013 that was using anything but “Default”, put it back and you will be good to go

 

image

 

Happy Searching.
Sean

23 Responses

  1. David says:

    I can’t get two inline searches to work properly on the same page, anyone else have this problem?

  2. Jeroen van Lieshout says:

    Had a similar issue like this on a SharePoint 2013 site. We had this issue especially on a migrated SharePoint 2010 sites. After investigation I found out that if the InlineEdit property is set to True the Client Rendering options like Display Search Box are also not available. You can solve this by clearing the InlineEdit property with custom code, because this option has been removed from the User Interface when modifying the view in SharePoint 2013.

  3. Adam Reyes says:

    Jeroen, where exactly do I need to modify the InlineEdit code? I tried looking through and modifying anything that said True to False but after much testing I can’t seem to get the issue resolved.

    • Jeroen says:

      Adam, you need to delete the InlineEdit property on each List View (just setting the property to False isn’t enough). I suggest that you use a tool like SharePoint Manager and check for each List View if the property is set.

  4. Jason says:

    I was so excited to see the inline search. Problem is, it doesn’t work for me. When I search for a term it always returns “Your search returned no results” Am I missing something that needs to be configured?

    Any help is appreciated.

    Thanks.

    Jason

  5. James says:

    Very many thanks for this post, I was getting frustrated trying to work out where the list search had gone. All good now.

  6. Marcel Meth says:

    The search seems to work fine on all fields in a list except for the title. How can I get the title to be searched?

  7. Danilo says:

    Thank You very much!

  8. Arif says:

    Hi Thanks, trying to find the boundaries for using the inline search in a populated list?
    say I have 1000s of items would it be advisable to use the inline search?
    Looking for MS guidelines (article or website) but cant find anything specific to the inline search?
    Help would be appreciated, as I need to justify using this over setting up a CSWP

    • itgadmin says:

      Hey there,

      I’d argue an inline search would be more efficient than a content search web part. The reason being that a user is requesting specific content from the inline search when needed only, and it will only pull content from the index so it will be quick and one time.

      A content search box is anticipating the content a user wants, on every page load.

      Really, they do two different things, but the above would be my argument for which is more efficient.

      Have a great day.

      • Arif says:

        Agreed, but is there any articles, MS or TechNet which would back that?
        I know what your saying makes sense but try explaining that to my colleague!

        • Sean Wallbridge says:

          Sorry Arif, I’d be Googling that myself. Good luck.

          • Arif says:

            Thanks Sean, I Have, looked at the MS SP boundaries also, but cant find anything specific to inline search…. will keep searching, but if anyone has stumbled across please let me know

  9. User says:

    Wow, this is a usefull article, can’t believe all other search results in Google were such a wste of time, while this one was spot on.

  10. Matt says:

    Thank you so much. I cannot believe I had to go through several pages of search results to find this answer. Great article and thank you.

  11. Kris says:

    This article was incredibly helpful even now.

    Hopefully this will help someone else, but I found out the hard way that if you hide a list from the browser, it will remove the search box automatically from the inline search (even if you mark the list as searchable). It makes perfect sense, but I had forgotten that the list was hidden since I have links to it. If you’re getting a search box that clears itself out in the web part configuration automatically, that could be the issue.

    • Holger says:

      Well, I was now checking the designer and I think I found the option in the settings part of the list. It is deactivated and was never active, but the search box doesn’t appear…

  12. Niko says:

    For me the only way to solve it was to create a new view.
    But thanks for the Post which gave me the right direction.

    Thanks

  13. Holger says:

    Hi There, thnaks for that article. Unfortunately all of the described solutions didn’t work out for me. I also tried to check the web part configuration and so on, but nothing helped to show up the search box for a list.
    Mabye it has soemthing to do because we are using SharePoint 2013 Foundation?

  14. Larry Sherrod says:

    Thanks for the tip. The search box came back as soon as I changed the style back to default.

  15. Christine says:

    THANK YOU. Very helpful! Have shared with site owners!

Leave a Reply

Sean Wallbridge

Sean Wallbridge-square-150x150

Beer Me!

Subscribe via Email

Categories

Powered by...

itgroove Corporate Profile
Connect With Us